Consultas, desarrollo de programas y petición de presupuestos:

jueves, 12 de julio de 2012

Menus y Calculadora

Vamos a hacer una minicalculadora que pueda sumar, restar, multiplicar ó dividir.
<inicio>
op=1
num1=0
num2=0
resul=0
mientras op!=0
    escribir “1 sumar”
    escribir “2 restar”
    escribir “3 multiplicar”
    escribir “4 dividir”
    escribir “0 Terminar”
    op=-1
    mientras op<0 O op>4
        Escribir “Seleccione la operación que desee realizar:”
        Leer op
    finmientras
    si op!=0
        escribir “Introduce un nº”
        leer num1
        escribir “Introduce otro nº”
        leer num2
        si op==1
            resul=num1+num2
        sino
              si op==2
                resul=num1-num2
             sino
                si op==3
                    resul=num1*num2
                sino
                    si op==4
                        resul=num1/num2
                    finsi
                finsi
            finsi
            Escribir resul
        finsi
finmientras
<fin>



No hay comentarios:

Publicar un comentario en la entrada