Consultas, desarrollo de programas y petición de presupuestos:

jueves, 12 de julio de 2012

Menus y Calculadora (III): Ejemplos de uso de funciones

Vamos a pedir un nº al usuario y tenemos que mostrar el sumatorio de ese número:
Nota: un sumatorio es la suma de todos los numeros entre la unidad y el mismo, ejemplo
Sumatorio(3)=1+2+3=6
<inicio>
num=0
sumatorio=0
num=PedirNumero("introduzca un nº")
sumatorio=Sumatorio(num)
escribir sumatorio
<fin>
-----------------------------------
<Sumatorio(num)>
valor=0
mientras num>=1
valor=valor+1
num--
fin mientras
devolver valor
<fin Sumatorio>

Vamos a mostrar la tabla de multiplicar de un nº que introduzca un usuario:
<inicio>
num=0
num=PedirNumero("introduce un nº)
EscribirTablaMultiplicar(num)
<fin>
----------------------------------------------------
<EscribirTablaMultiplicar(num)>
c=1
mientras c<=10
    Escribir num,"x",c,"=",num*c
    c++
fin mientras
devolver true
<fin EscribirTablaMultiplicar>

Nota:
La diferencia entre función y procedimiento, es que la función siempre devuelve un valor.

Vamos a hacer el pseudocódigo que hicimos de la tabla de multiplicar  con estos requisitos:
a) el nº que se le pide al usuario tiene que se positivo
b) se le pide un 2º numero que es la cantidad de lineas que queremos para la tabla
<inicio>
num1=0
num2=0
mientras num1=<0
    num1=pedir("introduzca num1:")
fin mientras
mientras num2=<0
    num2=pedir("introduzca num2:")
fin mientras
tabla_multiplicar(num1,num2)
<fin>

<tabla_multiplicar(a,b)>
c=1
mientras c<=b
escribir a
escribir "x"
escribir c
escribir "="
escribir a*c
c++
fin mientras
devolver true
<fin tabla_multiplicar>

Notas:
mientras num1=<0
en esta linea me aseguro que num1>0
mientras num2=<0
en esta linea me aseguro que num2>0
devolver true
Para que se función y no procedimiento.

No hay comentarios:

Publicar un comentario en la entrada