Consultas, desarrollo de programas y petición de presupuestos:

jueves, 12 de julio de 2012

Bucles: Prácticas y Ejercicios (III): Reloj y S/N

Mostrar 10 veces los numeros de 1 al 10:
<inicio>
contador1=1
contador2=0
mientras contador1<=10
        contador2=1
        mientras contador2<=10
            escribir contador2
            contador2++
        finmientras
        contador1++
finmientras
<fin>

Nota:
contador2=1 : aquí le asigno el valor inicial que me interesa

Escribre un pseudocódigo que simule el funcionamiento de un reloj digital (9:32:02), por un dia (24 horas)
<inicio>
h=0
m=0
s=0
mientras h<24
    mientras m<60
        mientras s<60
            Escribe h,m,s
            s++
        finmientras
        s=0
        m++
    finmientras
    m=0
    h++
finmientras
<fin>

Escribre un pseudocódigo que simule el funcionamiento de un reloj digital (9:32:02), por para siempre
<inicio>
h=0
m=0
s=0
mientras 3==3
    mientras h<24
         mientras m<60
            mientras s<60
                Escribe h,m,s
                s++
            finmientras
            s=0
            m++
        finmientras
        m=0
        h++
    finmientras
finmientras
<fin>

Nota:
mientras 3==3 es una condición que se cumple siempre, con lo cual tenemos un reloj perpetuo

Mostrar los numero del 1 al 10, mientras el usuario quiere seguir mostrandolo
<inicio>
n=1
res=”S”
mientras res==”S”
    n=1
    mientras n<=10
        escribir n
        n++
    finmientras
     res=” “
     mientras res!=”S” Y res!=”N”
                        escribir “¿otra vez? (S/N)”
                        Leer res
                        res=pasar_a_mayusculas(res)
       finmientras
finmientras
<fin>

Nota:
No es O porque si escribo la “N”, y pregunto , distinto de S, se cumpliaría la condición
Se usa la función pasar_a_mayusculas() convierte la letra en mayuscula.
Este sistema sistema siempre igual para las tipicas preguntas “SI/NO”.

No hay comentarios:

Publicar un comentario en la entrada