Consultas, desarrollo de programas y petición de presupuestos:

jueves, 12 de julio de 2012

Bucles: Prácticas y Ejercicios (II)

Ejercicios:
Vamos a pedir números por teclado al usuario. El usuario indicara que no quiere meter mas numeros introduciendo un cero. Mostraremos cuantos numeros a introducido.
<inicio>
numero=1
contador=0
mientras numero!=0
    Escribe “Introduce numero (0 para salir):”
    leer numero
    contador++
finmientras
Escribe “El nº de numeros introducidos es:”
Escribe contador
<fin>

Nota:
numero no puede tener valor inicial igual a 0, ya que no se ejecutaría el bucle

Introducir números por teclado y terminar cuando escriba el número cero. Y luego tenemos que mostrar el mayor número introducido.
<inicio>
num=1
max=0

Escribe “Introduce Numero (0 para salir):”
leer num
max=num

mientras num!=0
     escribe “Introduce Numero (0 para salir)”
     leer num
     si num>max
         max=num
     finsi
finmientras
Escribe “El numero mayor es:”
Escribe max
<fin>

Nota:
la parte en rojo la pongo porque asi el primer numero que ponga sera el max

Introducir numero por teclado hasta que introduzcamos cero y luego vamos a mostrar el mayor el menor y cuantos numeros se han introducido.
<inicio>
num=0
cantidad=0
max=0
min=0
Escribe “Introduzca un numero (0 para salir):”
leer num
max=num
min=num

mientras num!=0
    Escribe “Introduzca un numero (0 para salir):”
     leer num
    si num>max
         max=num
     finsi
     si num<min
         min=num
     finsi
    cantidad++
finmientras
Escribe “Se han introducido:”
Escribe cantidad
Escribe “El minimo es:”
Escribe min
Escribe “El maximo es:”
Escibe max
<fin>

Introducir números por teclado, terminamos con cero. Y vamos a mostrar los 2 mayores
<inicio>
num=0
max1=0
max2=0
Escribe “Escribe un numero (0 para salir)”
Leer num
max1=num
max2=num

mientras num!=0
     Escribe “Escribe un numero (0 para salir)”
     Leer num
     si num>max2
         max2=num
     finsi
     si num>max1
         max2=max1
         max1=num
     finsi
finmientras
Escribe “Numero maximo primero es”
Escribe max1
Escribe “Numero maximo segundo es”
Escribe max2
<fin>
Nota:
Cuando hay 2 mayores (o 3, o 4...), debemos de empezar siempre por el ultimos (en nuestro caso el 2º)

Introducir números por teclado y terminar con cero. Mostrar los dos números mayores que sean pares.
<inicio>
num=0
max=0
min=0
Escribir “Escribe numero (0 para salir)”
Leer num
mientras num!=0
     si num%2==0
         si num>max2
             max2=num
         finsi
     si num>max1
         max2=max1
         max1=num
     finsi
finmientras
Escribir “Escribe numero (0 para salir)”
Leer num
finmientras
Escribe “Numero maximo par primero:”
Escribe max1
Escribe “Numero maximo par segudo:”
Escribe max2
<fin>

Introducir números por teclado y terminamos con cero. Indicar cuantos son pares, cuantos impares, el mayor de los mares y el mayor de los impares.
<inicio>
num=0
cantidad_par=0
cantidad_impar=0
mayor_par=0
mayor_impar=0
Escribe “Introduce Numero (0 para salir)
leer num
mientras num!=0
     si num%2==0
        si num>mayor_par
             mayor_par=num
            cantidad_par++
         finsi
    sino
         si num>mayor_impar
             mayor_impar=num
             cantidad_impar++
         finsi
     finsi
finmientras
Escribe “Numeros pares introducidos”
Escribe cantidad_par
Escribe “El mayor de los pares ha sido”
Escribe mayor_par

Escribe “Numeros impares introducidos”
Escribe cantidad_impar
Escribe “El mayor de los impares ha sido”
Escribe mayor_impar
<fin>


Introducimos números y terminamos con cero. Mostramos la suma de todos los números pares mayores de 25 y la cantidad de números que no han cumplido los requisitos anteriores.
<inicio>
num=0
suma=0
Escribe “Introduce numero”
Leer num

mientras num!=0
     si num<=25
         nocumple++
     sino
     si num%2==0
         suma=suma+num
     finsi
finmientras
Escribe “Introduce numero”
Leer num
finmientras
Escribe “Numero que no han cumplido”
Escribe nocumple
Escribe “Suma de los numero superiores a 25 y que son pares:”
Escribre suma
<fin>

Otra forma:
<inicio>
suma=0
contador=0
num=0
vale=True
Escribir “Introduzca un numero:”
Leer num
mientras num!=0
     si num%2==0
         si num>25
             vale=true
         sino
            vale=false
        finsi
     sino
     vale=false
    finsi
     si vale==true
         suma=suma+num
     sino
         contador++
     finsi
    Escribir “Introduzca un numero”
    Leer num
finmientras
Escribir “Total suma:”,suma,”Total contador”,contador.
<fin>

Nota:
la variable “vale” es un “switch”, un “interruptor”, y tenemos que activarlo activarlo o desactivarlo según las opciones.

Vamos a sumar por un lado los números pares y por otro los numero impares entre 1 y 10, pero sin usar el operador %
<inicio>
sumaimpar=0
sumapar=0
num=1
par=false
mientras num<=10
     si par==true
         sumapar=sumapar+num
     sino
         sumaimpar=sumaimpar+num
     finsi
     par= !par
     num++
finmientras
Escribe “Suma par:”,sumapar,”Suma impar:”,sumaimpar
<fin>

No hay comentarios:

Publicar un comentario en la entrada