Consultas, desarrollo de programas y petición de presupuestos:

jueves, 12 de julio de 2012

Bucles: Prácticas y Ejercicios (I)

Vamos a mostrar los numero del 1 al 25:
<inicio>
n=1
mientras n<=25
     escribir n
     n=n+1
fin mientras
<fin>
Nota:
Tambien se podria poner en vez de n<=25, poner n<26

Calcular la suma de los números del 1 al 10 :

<inicio>
n1=1
suma=0
mientras n<=10
suma=suma+n1
n1++
fin mientras
escribir suma
<fin>
Num N1...........Suma................operaciones..........contador
1..........................0......................s=s+n1.................n1++
2..........................1.....................1=0+1..................1+1
3..........................3......................3=1+2..................2+1
4.........................6.......................6=3+3..................3+1
5........................10...................... 10=6+4



Mostrar números pares del 1 al 50:
<inicio>
n=2
suma=0
mientras n<=50
    suma=suma+n
     escribir suma
     n=n+2
fin mientras
<fin>

Otra forma de hacerlo
<inicio>
n=1
mientras n<=50
     si num%2==0
         escribir num
     finsi
     n=n+1
finmientras
<fin>

Sumar por un lado los números pares y por otro lado los impares entre 1 y 50:
<inicio>
num=1
par=0
impar=0
mientras num<=50
    si num%2==0
         par=par+num
     si no
         impar=impar+num
     fin si
    num=num+1
fin mientras
escribir par,impar
<fin>

Queremos saber que es mayor, si la suma de los múltiplos de 3 entre 1 y 50 ó la suma de los multiplos de 5 entre 1 y 30:
<inicio>
num=1
m3=0
m5=0
mientras num<=50
    si num%3==0
         m3=m3+num
     sino
         si num%5==0 y num<=30
             m5=m5+num
         finsi
     finsi
    num=num+1
finmientras
si m5>m3
    escribir m5
sino
     escribir m3
finsi
<fin>        

Vamos a mostrar los 32 primeros múltiples de 3:
<inicio>
veces=0
num=1
mientras veces <32
     si num%3==0
         escribir num
         veces=veces+1
     fin si
    num=num+1
fin mientras
<fin>

Vamos a mostrar multiplos de 3 ó de 5, el programa va a mostrar los 10 primeros sean del tipo que sean.
<inicio>
n=1
c=1
mientras c<=10
    si n%3==0
         escribe n+”multiplo de 3”
         c++
     sino
         si n%5==0
             escribe n+”multiplo de 5”
             c++
         finsi
     finsi
finmientras
<fin>

Otra forma:
<inicio>
veces=0
num=1
mientras veces<10
       si num%3==0 ó num%5==0
            escribir num
            veces=veces+1
        fin si
        num=num+1
fin mientras
<fin>

Mostrar múltiplos de un número que indique el usuario comprendidos entre 1 y 100.
<inicio>
num=1
numU=0
escribir “introduce nº entre 1 y 100:”
leer numU
mientras num<=100
     si num%numU==0
         escribir num
     finsi
    num++
finmientras
<fin>

Solicitar al usuario 2 numeros, asegurando que el 1º numero es menor que el 2º y mostrar todos los numeros comprendidos entre ambos.
<inicio>
n1=0
n2=0
contador=0
aux=0
Escribir “introduzca un nº1:”
Leer n1
Escribir “introduzca un nº mayor que nº1:”
leer n2
si n1>n2
     aux=n1
     n1=n2
     n2=aux
finsi
contador=n1
mientras contador<=n2
     escribir contador
     contador=contador+1
finmientras
<fin>
Otra forma de ver el ejercicio:
<inicio>
n1=0
n2=0
contador=0
Escribir “introducir un nº”
leer n1
n2=n1+1
mientras n1<n2
     escribir “introduzca un nº”
     Leer n2
fin mientras
contador=n1
mientras contador<=n2
     escribir contador
     contador=contador+1
finmientras
<fin>

Pedir 3 numeros al usuario y mostrarnos los múltiplos del 1º comprendidos entre 2º y el 3º
<inicio>
n1=0
n2=0
n3=0
escribir “Introduzca 3 numeros:”
leer n1,n2,n3
si (n2>n3)
    aux=n2
     n2=n3
     n3=aux
finsi
mientras (n2<=n3)
     si (n2%n1==0)
         escribir n2
     finsi
    n2=n2+1
fin mientras
<fin>

No hay comentarios:

Publicar un comentario en la entrada